This project has moved and is read-only. For the latest updates, please go here.

Teamspeak 3 Service Wrapper on Windows Server 2012

Jan 24, 2013 at 5:22 PM

This Website is given as the author Website of Teamspeak 3 Service Wrapper, so I'm hoping I'll find help on that issue here ;-)

I've also posted that on the TeamSpeak forums, so I'll just copy'n'paste my message from there:

I'm not perfectly sure my issue is related to Windows Server 2012 - but as I've had TeamSpeak installed as service without any trouble on a Windows Server 2008R2 box, this is the only reason I can think of.

Basically, TeamSpeak runs fine when started via Explorer or console, there service is "installed correctly" as far as I can tell (TS3ServiceWrapper.InstallLog says "Service TS3Server has been successfully installed."). For testing, I'm using an administrator user to run the service - so there shouldn't be any permissions issues ... but still, when trying to start the service, I'm getting:

Windows could not start the TS3Server service on Local Computer.

Error 1053: The service did not respond to the start or control request in a timely fashion.

TeamSpeak server and TS3ServiceWrapper are both the most current versions (as far as I can tell). TeamSpeaker server:, TS3ServiceWrapper: (2010-03-12).

Any ideas what's going wrong?


URL of the thread on the TeamSpeak forum:

Jan 24, 2013 at 5:48 PM


In some cases the firewall dialog that is asking to block the process may appear and when the process is hidden the dialog is not answered which causes the service startup to fail.


- change config to not hide the process

- start the service as console app using the same credentials you would use when running the service

- see whats happening

Jan 26, 2013 at 1:12 PM

Ah, should have tried running it directly with the process not being hidden in first place, sorry.

It turned out that the problem was that I only had .NET 4.5 installed on that server. But TS3ServiceWrapper depends on .NET 3.5. I fixed the path for the installer (that had complained earlier) - but the service didn't run without 3.5. Thank you for support - it works now :-)